System Requirements


3D Invigorator PRO and 3D Invigorator Classic Plug-ins for After Effects

Macintosh

    • Host: Adobe After Effects CS5 - CS6 and After Effects CC 2014.
      • For users working with After Effects CS3 - CS4, please contact us for older versions of the plug-in.
    • Intel Mac Only
    • Mac OS X 10.6, 10.7, 10.8 or higher.
    • A video card that supports floating point calculations.

Windows

    • Host: Adobe After Effects CS5 - CS6 and After Effects CC 2014.
      • For users working with After Effects CS3 - CS4, please contact us for older versions of the plug-in.
    • Pentium 4 or better
    • Windows Vista, Windows 7 or Windows 8
    • A video card that supports floating point calculations.

ProAnimator Plug-in for After Effects

Macintosh

    • Host: Adobe After Effects CS5 - CS6 and After Effects CC 2014.
      • For users working with After Effects CS3 - CS4, please contact us for older versions of the plug-in.
    • Intel Mac Only
    • Mac OS X 10.7, 10.8 or higher.
    • A video card that supports floating point calculations.

Windows

    • Host: Adobe After Effects CS5 - CS6 and After Effects CC 2014.
      • For users working with After Effects CS3 - CS4, please contact us for older versions of the plug-in.
    • Pentium 4 or better
    • Windows Vista, Windows 7 or Windows 8
    • A video card that supports floating point calculations.

ProAnimator Standalone Application

Macintosh

    • Intel Mac Only
    • Mac OS X 10.7, 10.8 or higher.
    • A video card that supports floating point calculations.

Windows

    • Pentium 4 or better
    • Windows Vista, Windows 7 or Windows 8
    • A video card that supports floating point calculations.

ProModeler Application

Macintosh

    • Intel Mac Only
    • Mac OS X 10.5.8 and higher

Windows

    • Pentium 4 or better
    • Windows Vista, Windows 7 or Windows 8
    • Quicktime 7 or DirectX 9

3D Flag Plug-in for After Effects

Macintosh

    • Host: Adobe After Effects CS5 - CS6 and After Effects CC 2014
    • Intel Mac ONLY

Windows

    • Host: Adobe After Effects CS5 - CS6 and After Effects CC 2014
    • Pentium 4 or better
    • Windows Vista, Windows 7 or Windows 8
    • Quicktime 7.4 or higher

3D Flag Plug-in for Motion and Final Cut Pro

Macintosh

    • Host: Apple Motion, 3, & 4 and Final Cut Pro 6 & 7
    • Intel Mac ONLY
    • Mac OS X 10.4.11 - 10.8 (OSX Mavericks not supported)

3D Layer Tools Plug-in for After Effects

Macintosh

    • Host: Adobe After Effects CS3 - CS6 and After Effects CC 2014.
    • Intel Mac Only
    • Mac OS X 10.5.8 (must use After Effects CS5 - CS6)
    • Mac OS X 10.6 - 10.9 can use After Effects CS3 - CS6 and After Effects CC 2014.
    • A video card that supports floating point calculations.

Windows

    • Host: Adobe After Effects CS3 - CS6 and After Effects CC 2014.
    • Pentium 4 or better
    • Windows Vista, Windows 7 or Windows 8
    • A video card that supports floating point calculations.

3D Reflector Plug-in for After Effects

Macintosh

    • Host: Adobe After Effects CS3 - CS6 and After Effects CC 2014.
    • Intel Mac Only
    • Mac OS X 10.5.8 (must use After Effects CS5 - CS6)
    • Mac OS X 10.6 - 10.8 can use After Effects CS3 - CS6 and After Effects CC 2014.
    • A video card that supports floating point calculations.

Windows

    • Host: Adobe After Effects CS3 - CS6 and After Effects CC 2014.
    • Pentium 4 or better
    • Windows Vista, Windows 7 or Windows 8
    • A video card that supports floating point calculations.

3D Serpentine Plug-in for After Effects

Macintosh

    • Host: Adobe After Effects CS3 - CS6 and After Effects CC 2014.
    • Intel Mac Only
    • Mac OS X 10.5.8 (must use After Effects CS5 - CS6)
    • Mac OS X 10.6 - 10.8 can use After Effects CS3 - CS6 and After Effects CC 2014.
    • A video card that supports floating point calculations.

Windows

    • Host: Adobe After Effects CS3 - CS6 and After Effects CC 2014.
    • Pentium 4 or better
    • Windows Vista, Windows 7 or Windows 8
    • A video card that supports floating point calculations.

3D Warps Plug-in Plug-in for After Effects

Macintosh

    • Host: Adobe After Effects CS3 - CS6 and After Effects CC 2014.
    • Intel Mac Only
    • Mac OS X 10.5.8 (must use After Effects CS5 - CS6)
    • Mac OS X 10.6 - 10.8 can use After Effects CS3 - CS6 and After Effects CC 2014.
    • A video card that supports floating point calculations.

Windows

    • Host: Adobe After Effects CS3 - CS6 and After Effects CC 2014.
    • Pentium 4 or better
    • Windows Vista, Windows 7 or Windows 8
    • A video card that supports floating point calculations.

The Werks Vol. 1 Plug-in for After Effects

Macintosh

    • Host: Adobe After Effects CS3 - CS6 and After Effects CC 2014.
    • Intel Mac Only
    • Mac OS X 10.5.8 (must use After Effects CS5 - CS6)
    • Mac OS X 10.6 - 10.8 can use After Effects CS3 - CS6 and After Effects CC 2014.
    • A video card that supports floating point calculations.

Windows

    • Host: Adobe After Effects CS3 - CS6 and After Effects CC 2014.
    • Pentium 4 or better
    • Windows Vista, Windows 7 or Windows 8
    • A video card that supports floating point calculations.

ProAnimator FX Plug-In for Motion and Final Cut Pro

Macintosh

    • Host: Apple Final Cut Pro 6 & 7 or Motion 3 & 4
    • G5 Power Mac or Intel Mac
    • Mac OS X 10.4.11 - 10.8 (OSX Mavericks not supported)
    • Quicktime 7.4 or higher